Degraded Performance
Incident Report for TeamViewer
Resolved
All our systems are now back online and functional.
Posted about 1 month ago. Nov 15, 2018 - 16:53 CET
Investigating
A subset of our users are currently experiencing latency when accessing our services. Our engineers have not yet confirmed the underlying root cause. We will update our status page as soon as possible.
Posted about 1 month ago. Nov 15, 2018 - 16:26 CET
This incident affected: TeamViewer Services and Management Console.