Degraded Performance
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 29, 2018 - 18:12 CET
Update
The issue has been resolved. Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted 10 months ago. Oct 29, 2018 - 18:10 CET
Investigating
A subset of our users are currently experiencing latency when accessing our services. Our engineers have not yet confirmed the underlying root cause. We will update our status page as soon as possible.
Posted 10 months ago. Oct 29, 2018 - 09:06 CET