Chat and Partner List Issue
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 11 months ago. Feb 01, 2018 - 13:39 CET
Identified
Our users are currently experiencing latency when accessing our service TeamViewer. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.
Posted 11 months ago. Feb 01, 2018 - 13:03 CET