Issues detected
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted Jul 12, 2017 - 02:38 CEST
Investigating
Our users are currently experiencing latency or errors when accessing our service TeamViewer. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.
Posted Jul 12, 2017 - 02:02 CEST