Issues when downloading TeamViewer
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 30, 2017 - 23:01 CET
Investigating
A subset of our users are currently experiencing latency or errors when accessing our website. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted about 1 year ago. Nov 30, 2017 - 22:44 CET