Degraded Performance
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 22 days ago. Oct 30, 2018 - 12:34 CET
Monitoring
Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted 22 days ago. Oct 30, 2018 - 12:02 CET
Update
We are continuing to investigate this issue.
Posted 22 days ago. Oct 30, 2018 - 11:47 CET
Investigating
A subset of our users are currently experiencing latency when accessing our services. Our engineers have not yet confirmed the underlying root cause. We will update our status page as soon as possible.
Posted 22 days ago. Oct 30, 2018 - 09:35 CET
This incident affected: TeamViewer Services and Management Console.