Issues
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted Jun 26, 2017 - 04:18 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2017 - 04:09 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 26, 2017 - 03:54 CEST
Investigating
A subset of our users are currently experiencing latency when accessing our service. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted Jun 26, 2017 - 03:44 CEST