Issue since 02:00 pm
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 05, 2017 - 15:18 CEST
Identified
Our users are currently experiencing latency or errors when accessing our service Remote Control and Meetings. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.
Posted 4 months ago. Jun 05, 2017 - 14:29 CEST