Performance issues
Incident Report for TeamViewer
Resolved
The issue has been resolved. Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted about 1 year ago. Dec 14, 2017 - 14:16 CET
Identified
Our users are currently experiencing latency or errors when accessing our services. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.
Posted about 1 year ago. Dec 14, 2017 - 13:59 CET