TeamViewer website unreachable
Incident Report for TeamViewer
Resolved
The issue has been resolved. Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted about 2 months ago. Oct 18, 2018 - 21:10 CEST
Monitoring
We are monitoring the systems currently.
Posted about 2 months ago. Oct 18, 2018 - 20:46 CEST
Identified
Our users are currently experiencing latency or errors when accessing our TeamViewer website. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update as soon as possible.
Posted about 2 months ago. Oct 18, 2018 - 16:29 CEST
This incident affected: Website.