Connectivity Issue
Incident Report for TeamViewer
Resolved
The issue has been resolved. Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted 10 months ago. Feb 28, 2018 - 14:01 CET
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Feb 28, 2018 - 13:03 CET