Degraded Performance
Incident Report for TeamViewer
Resolved
All our systems are now back online and functional.
Posted 8 months ago. Nov 16, 2018 - 10:03 CET
Identified
Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted 8 months ago. Nov 16, 2018 - 09:55 CET
Investigating
A subset of our users are currently experiencing latency when accessing our services. Our engineers have not yet confirmed the underlying root cause. We will update our status page as soon as possible.
Posted 8 months ago. Nov 16, 2018 - 09:31 CET
This incident affected: TeamViewer Services, Management Console, and API.