Degraded Performance
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted about 1 month ago. Jan 17, 2019 - 11:04 CET
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jan 17, 2019 - 11:03 CET
Investigating
A subset of our users are currently experiencing latency when accessing our services. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted about 1 month ago. Jan 17, 2019 - 10:48 CET
This incident affected: TeamViewer Services and Management Console.