Connectivity Issue
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 10, 2018 - 15:38 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Oct 10, 2018 - 14:29 CEST
Investigating
Our users are currently experiencing errors when trying to establish a remote connection. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted 10 months ago. Oct 10, 2018 - 14:08 CEST
This incident affected: TeamViewer Services.