Connectivity Issue
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 01, 2018 - 15:43 CET
Identified
A subset of our users are currently experiencing latency when accessing our service TeamViewer. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.”
Posted 8 months ago. Mar 01, 2018 - 15:21 CET