Resetting forgotten passwords not working at the moment
Incident Report for TeamViewer
Resolved
All systems are back to normal.
Posted 6 months ago. Jun 15, 2018 - 17:40 CEST
Identified
During routine maintenance work, a system component could not be reinitialized as expected. Therefore, some of our customers may experience difficulties when trying to reset forgotten passwords. Our team identified the root cause and currently works on resolving the issue. We will publish the next status update at the latest in 24 hours.
Posted 6 months ago. Jun 13, 2018 - 15:54 CEST
This incident affected: TeamViewer Services.