TeamViewer Website and Webshop
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 8 months ago. Dec 18, 2017 - 13:52 CET
Identified
Our users are currently experiencing latency when accessing our service TeamViewer Website. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.
Posted 8 months ago. Dec 18, 2017 - 13:47 CET