Connectivity Issue
Incident Report for TeamViewer
Resolved
The issue has been resolved. Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted 7 months ago. Mar 17, 2018 - 17:40 CET
Identified
Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.
Posted 7 months ago. Mar 17, 2018 - 17:34 CET
Investigating
Our users are currently experiencing latency or errors when accessing our service TeamViewer. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted 7 months ago. Mar 17, 2018 - 17:21 CET