Webshop down
Incident Report for TeamViewer
Resolved
The issue has been resolved. Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted about 2 months ago. Apr 23, 2018 - 13:13 CEST
Investigating
Our users are currently experiencing latency or errors when accessing our service Webshop. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted about 2 months ago. Apr 23, 2018 - 12:40 CEST