Connectivity Issue
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 05, 2018 - 10:45 CET
Investigating
Our users are currently experiencing latency or errors when accessing our service TeamViewer. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted 4 months ago. Mar 05, 2018 - 10:42 CET