Connectivity issue
Incident Report for TeamViewer
Resolved
This Incident has been resolved
Posted 4 months ago. Jun 18, 2019 - 04:27 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 18, 2019 - 04:14 CEST
Identified
Our engineers have advised the issue has been identified and are working towards a resolution
Posted 4 months ago. Jun 18, 2019 - 04:06 CEST
Investigating
A subset of our users are currently experiencing a connectivity issue when accessing our services. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted 4 months ago. Jun 18, 2019 - 03:44 CEST
This incident affected: TeamViewer Services and Management Console.