Connectivity issue
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 29 days ago. Aug 23, 2018 - 18:20 CEST
Monitoring
The issue has been resolved. Our engineers are still monitoring our systems to assure the situation is completely mitigated.
Posted 29 days ago. Aug 23, 2018 - 15:59 CEST
Identified
Our users are currently experiencing latency or errors when accessing our services. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.
Posted 29 days ago. Aug 23, 2018 - 15:11 CEST
This incident affected: TeamViewer Services, Management Console, and API.