Issues with REACH API

Incident Report for TeamViewer

Resolved

The incident has been resolved and we will continue to monitor the situation closely to prevent further service impact.
Posted Jun 10, 2025 - 13:30 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2025 - 11:35 CEST

Identified

We are currently experiencing a high load on our API servers. The issue has been identified and we're looking into it.
Posted Jun 10, 2025 - 11:20 CEST

Investigating

We are currently experiencing a high load on our API servers and are investigating the issue.
Posted Jun 10, 2025 - 09:48 CEST
This incident affected: API.