A fix has been deployed and validation confirms that data is now visible across all screens. We are continuing to monitor the platform over the weekend to ensure the issue remains resolve
Posted Jul 18, 2026 - 11:31 CEST
Identified
We have identified the issue and a fix is currently being implemented. Please note there may be temporary disruptions to service and to 1E client connectivity during the fix window.
Posted Jul 17, 2026 - 16:05 CEST
Investigating
We are currently experiencing an intermittent issue affecting the Normalized, Unmatched, and Software inventory pages within Inventory Insights. When loading these pages, a "No Data" message may be displayed.
Our engineering team is actively working on a fix. We will provide a further update at 16:00 UTC.
Posted Jul 17, 2026 - 15:12 CEST
This incident affects: DEX Platform and Solutions (DEX Platform – UK South 1, DEX Platform – North Europe 1, DEX Platform – West Europe 1, DEX Platform – East US 1, DEX Platform – West US 1, DEX Platform – Canada Central 1).