Degraded Performance
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted Nov 29, 2023 - 22:48 CET
Identified
A subset of our users is currently experiencing latency or errors when accessing TeamViewer and the Management Console, primarily in the United States. Our engineers have identified a preliminary root cause and are working to mitigate the issue. We will publish the next status update as soon as possible.
Posted Nov 29, 2023 - 20:00 CET
This incident affected: TeamViewer Services and Management Console.