Degraded Performance with management console
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted May 12, 2021 - 20:10 CEST
Update
We are continuing to monitor for any further issues.
Posted May 12, 2021 - 19:16 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2021 - 19:16 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 12, 2021 - 17:45 CEST
Investigating
A subset of our users are currently experiencing latency when accessing our management console. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted May 12, 2021 - 17:00 CEST
This incident affected: Management Console and IoT.