Wrong timestamps

Incident Report for TeamViewer

Resolved

Identified - a server node switched to an erroneous time, resulting in some events and action having a wrong timestamp

Monitoring - A fix is implemented and we are assessing the impact of the incident
Posted Jul 26, 2023 - 05:00 CEST