Connectivity Issue
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 21, 2018 - 14:37 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Aug 21, 2018 - 14:06 CEST
Update
We are still continuing to investigate this issue.
Posted about 1 month ago. Aug 21, 2018 - 11:34 CEST
Update
We are still continuing to investigate this issue.
Posted about 1 month ago. Aug 21, 2018 - 10:36 CEST
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Aug 21, 2018 - 09:09 CEST
Investigating
A subset of our users are currently experiencing latency when accessing our service. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted about 1 month ago. Aug 21, 2018 - 09:06 CEST
This incident affected: Website, TeamViewer Services, Management Console, and API.