DEX Client Connectivity issues with West Europe 1

Incident Report for TeamViewer

Resolved

This incident has now been resolved. No further connectivity issues have been observed.
Posted Mar 03, 2026 - 20:14 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 18:57 CET

Investigating

We are investigating an issue which is causing client disconnections from the West Europe 1 switch infrastructure.
Clients will reconnect automatically.
We will keep you updated with the status of this issue.
Posted Mar 03, 2026 - 17:01 CET
This incident affected: DEX Platform and Solutions (DEX Platform – West Europe 1).