Degraded Performance - Managed devices

Incident Report for TeamViewer

Monitoring

We fixed the issue which caused the degraded performance and can see that it has stabilized. We are continuing to monitor the situation. We will update our status page with new information as soon as possible.
Posted Apr 28, 2026 - 08:25 CEST

Identified

A subset of our users are currently experiencing technical issues with managed devices visibility. Our engineers are working on the issue. We will update our status page with new information as soon as possible.
Posted Apr 28, 2026 - 07:46 CEST
This incident affects: TeamViewer Services and Management Console.