Connectivity issue
Incident Report for TeamViewer
Resolved
We fixed the connectivity issue and all our systems are back online and functional.
Posted 5 months ago. May 20, 2019 - 16:16 CEST
Investigating
A subset of our users are currently experiencing a connectivity issue when accessing our services. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted 5 months ago. May 20, 2019 - 16:12 CEST
This incident affected: TeamViewer Services.