Potential delay when sending product e-mails

Incident Report for TeamViewer

Resolved

We fixed the degraded performance and all our systems are back online and functional.
Posted Jan 27, 2026 - 11:45 CET

Monitoring

We fixed the issue which caused the degraded performance and we are monitoring the results.
Posted Jan 27, 2026 - 11:30 CET

Investigating

A subset of our users can experience a delay in product e-mail delivery.
Posted Jan 27, 2026 - 11:12 CET
This incident affected: TeamViewer Services.