Partnerlist Issue

Incident Report for TeamViewer

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 11:08 CET

Investigating

We are currently investigating an issue with our Partnerlist.
Posted Nov 05, 2025 - 10:45 CET
This incident affected: TeamViewer Services and Management Console.