Reassignment of Unique IDs
Incident Report for TeamViewer
Resolved
All TeamViewer systems are back to normal operations.
Posted 20 days ago. Jul 25, 2018 - 13:15 CEST
Monitoring
We were able to resolve the server load issue. TeamViewer services should be up and running normally again for most of our users. We will continue to monitor all systems in order to ensure mitigation is complete. We would like to apologize for any inconvenience experienced by our users.
Posted 21 days ago. Jul 24, 2018 - 17:54 CEST
Update
The implementation of today’s precautionary measure resulted in a very high server load. A larger group of users are currently experiencing service degradation. We are working to resolve the issue and get our systems up and running normally as soon as possible. We would like to apologize for any inconvenience experienced by our users.
Posted 21 days ago. Jul 24, 2018 - 16:09 CEST
Identified
Based on global cooperation against malicious cyber activities, TeamViewer’s team and leading security researchers perform regular threat prevention analysis to identify inconsistent or suspicious behaviour within and beyond its network. In this context, in-depth data analysis revealed patterns of connection attempts that deviated from expected usage scenarios of TeamViewer. As this observation was limited to a small subgroup of endpoints, TeamViewer decided to invalidate and automatically re-assign unique identifiers (TeamViewer IDs) within this subgroup.

The precautionary measure has successfully been rolled out to full effect. For a short period of time, some users may experience service degradation, which will be resolved as soon as possible.
Posted 21 days ago. Jul 24, 2018 - 14:49 CEST
This incident affected: TeamViewer Services, Management Console, and API.