Device groups are not loading

Incident Report for TeamViewer

Resolved

We fixed the issue and all our systems are back and functional.
Posted Dec 10, 2025 - 12:44 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2025 - 11:35 CET

Investigating

We are currently investigating an issue with Device groups not loading.
Posted Dec 10, 2025 - 09:59 CET
This incident affected: TeamViewer Services.