Issues with TeamViewer Components
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted May 23, 2024 - 16:30 CEST
Monitoring
The issue has been addressed and we are monitoring the systems to guarantee the service.
Posted May 23, 2024 - 15:00 CEST
Update
Services should be back to normal, but initial connection to the TeamViewer network may be slow.
Posted May 23, 2024 - 14:41 CEST
Identified
We´ve applied measures and are recovering slowly. We monitor and apply further measures to mitigate the remaining impact.
Posted May 23, 2024 - 13:12 CEST
Investigating
We identified an issue that has impact to our services and are applying measures to restore service.
Posted May 23, 2024 - 11:50 CEST
This incident affected: TeamViewer Services, Management Console, API, IoT, Monitoring & Asset Management, Web Monitoring, Backup, and Endpoint Protection.