Degraded Performance
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 02, 2019 - 16:21 CEST
Identified
Our engineers identified the underlying root cause for the degraded performance and are working on the resolution. We will update our status page with new information as soon as possible.
Posted 3 months ago. Jul 02, 2019 - 15:54 CEST
This incident affected: Website.