Degraded Performance
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 13 days ago. Jul 09, 2019 - 13:47 CEST
Update
We are continuing to monitor for any further issues.
Posted 13 days ago. Jul 09, 2019 - 13:47 CEST
Monitoring
We fixed the issue which caused the degraded performance and we are monitoring the results as we send partial traffic on it. It looks good so far. We will update our status page with new information as soon as possible.
Posted 13 days ago. Jul 09, 2019 - 13:08 CEST
Investigating
A subset of our users are currently experiencing latency when accessing our Services. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted 13 days ago. Jul 09, 2019 - 12:14 CEST
This incident affected: Management Console.