Degraded Performance
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 11, 2019 - 13:33 CEST
Monitoring
We fixed the issue which caused the degraded performance and we are monitoring the results as we send partial traffic on it. It looks good so far. We will update our status page with new information as soon as possible.
Posted 4 months ago. Apr 11, 2019 - 12:44 CEST
Update
We are still working on the complete resolution of the issue to get everyone back online. We are seeing good results by sending more and more traffic back on our network. We will update our status page with new information as soon as possible.
Posted 4 months ago. Apr 11, 2019 - 12:13 CEST
Update
Our engineers identified the underlying root cause for a connectivity issue and are working on the resolution. We will update our status page with new information as soon as possible.
Posted 4 months ago. Apr 11, 2019 - 11:36 CEST
Update
We see more and more users being able to work again, and we are still working on the resolution of the issue to get everyone back online. We will update our status page with new information as soon as possible.
Posted 4 months ago. Apr 11, 2019 - 11:02 CEST
Identified
Our engineers identified the underlying root cause for the degraded performance and are working on the resolution. We will update our status page with new information as soon as possible.
Posted 4 months ago. Apr 11, 2019 - 09:55 CEST
Investigating
A subset of our users are currently experiencing latency when accessing our services. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted 4 months ago. Apr 11, 2019 - 09:22 CEST
This incident affected: TeamViewer Services, Management Console, and API.