Degraded Performance
Incident Report for TeamViewer
Resolved
All our systems are now back online and functional.
Posted 4 months ago. Dec 03, 2018 - 12:17 CET
Identified
A subset of our users are currently experiencing latency when accessing our services. Our engineers are working on the issue.
We will update our status page as soon as possible.
Posted 4 months ago. Dec 03, 2018 - 11:48 CET
This incident affected: TeamViewer Services, Management Console, and API.