Connectivity issue
Incident Report for TeamViewer
Resolved
We fixed the connectivity issue and all our systems are back online and functional.
Posted 5 months ago. May 02, 2019 - 23:48 CEST
Identified
Our engineers identified the underlying root cause for a connectivity issue and are working on the resolution. We will update our status page with new information as soon as possible.
Posted 5 months ago. May 02, 2019 - 22:33 CEST
This incident affected: Management Console.