Degraded Performance
Incident Report for TeamViewer
Resolved
We fixed the degraded performance and all our systems are back online and functional.
Posted 25 days ago. Jan 25, 2019 - 09:02 CET
Monitoring
Monitoring - We fixed the issue which caused the degraded performance and we are monitoring the results as we send partial traffic on it. It looks good so far.
Posted 25 days ago. Jan 25, 2019 - 08:48 CET
Investigating
A subset of our users are currently experiencing latency when accessing our services. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted 25 days ago. Jan 25, 2019 - 08:31 CET
This incident affected: TeamViewer Services, Management Console, and API.