Device groups issue

Incident Report for TeamViewer

Resolved

This incident has been resolved.
Posted Nov 28, 2024 - 15:43 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2024 - 15:11 CET

Identified

Our engineers identified the underlying root cause and are working on the resolution. We will update our status page with new information as soon as possible.
Posted Nov 28, 2024 - 14:53 CET

Investigating

A subset of users experience issues with device groups not appearing or missing devices in the groups.
Posted Nov 28, 2024 - 14:16 CET
This incident affected: TeamViewer Services and Management Console.