Issue with TeamViewer license validation

Incident Report for TeamViewer

Resolved

We fixed the overall issue and all our systems are now functional. Latest after a TeamViewer service restart, the pop-up message should disappear.
Posted Mar 25, 2026 - 13:33 CET

Monitoring

We fixed the issue with the license validation and we are monitoring the results. Affected users should restart the TeamViewer Service and try again. We will update our status page with new information as soon as possible.
Posted Mar 25, 2026 - 13:00 CET

Investigating

A subset of our users are currently experiencing a pop-up with license validation. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted Mar 25, 2026 - 12:50 CET
This incident affected: TeamViewer Services and Management Console.