Phone system issues
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted Dec 21, 2020 - 14:07 CET
Identified
Our engineers identified the underlying root cause for a phone system issue and are working on the resolution. If you require immediate assistance, please create a ticket in our support page (support.teamviewer.com). We will update our status page with new information as soon as possible.
Posted Dec 21, 2020 - 13:50 CET
This incident affected: Phone System.