Decreased Performance

Incident Report for TeamViewer

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 14:38 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2025 - 14:14 CET

Update

We are continuing to investigate this issue.
Posted Mar 05, 2025 - 13:13 CET

Update

We are continuing to investigate this issue.
Posted Mar 05, 2025 - 13:10 CET

Investigating

We are currently investigating an issue with decreased product performance.
Posted Mar 05, 2025 - 12:56 CET
This incident affected: TeamViewer Services, Management Console, API, IoT, Monitoring & Asset Management, Web Monitoring, Backup, and Endpoint Protection.