Degraded Performance
Incident Report for TeamViewer
Resolved
We fixed the degraded view and all our communities are functional again.
Posted 2 months ago. May 16, 2019 - 10:42 CEST
Investigating
A subset of our users are currently experiencing a degraded view when accessing our communities. We are working on the identification and will update our status page with new information as soon as possible.
Posted 2 months ago. May 15, 2019 - 20:37 CEST
This incident affected: TeamViewer Community.