Connectivity issue
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted Jan 31, 2021 - 03:46 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 31, 2021 - 03:40 CET
Investigating
Our users are currently experiencing latency or errors when accessing our services. Our engineers have not yet confirmed the underlying root cause. We will publish the next status update at the latest in 60 minutes.
Posted Jan 31, 2021 - 03:18 CET
This incident affected: TeamViewer Services, Management Console, API, IoT, Monitoring & Asset Management, Backup, Endpoint Protection, and Web Monitoring.