Issues accessing our online services
Incident Report for TeamViewer
Resolved
This incident has been resolved.
Posted 2 months ago. May 09, 2019 - 15:25 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. May 09, 2019 - 14:34 CEST
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. May 09, 2019 - 13:01 CEST
Identified
Our users are currently experiencing latency or errors when accessing our online services. Our engineers identified a preliminary root cause and are trying to mitigate the issue. We will publish the next status update at the latest in 60 minutes.
Posted 2 months ago. May 09, 2019 - 12:20 CEST
This incident affected: Management Console and API.