Degraded Performance - Custom modules

Incident Report for TeamViewer

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 09:52 CEST

Investigating

A subset of our users are currently experiencing issues with downloading custom modules. Our engineers have not yet confirmed the underlying root cause and they are working on the identification. We will update our status page with new information as soon as possible.
Posted Jun 10, 2026 - 08:41 CEST
This incident affected: Website.